Header Ads

Header Ads

Mac OS X on Dell inspiron 3542

Hi,



Today i will post the new page about installing Mac OS X on Dell Inspiron 3542 laptop and then fixing the issues, making it to work stable and without problems. First of all lets look into this laptop hardware specs:

00:00.0 Host bridge: Intel Corporation Haswell-ULT DRAM Controller (rev 0b)
00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 0b)
00:03.0 Audio device: Intel Corporation Haswell-ULT HD Audio Controller (rev 0b)
00:14.0 USB controller: Intel Corporation Lynx Point-LP USB xHCI HC (rev 04)
00:16.0 Communication controller: Intel Corporation Lynx Point-LP HECI #0 (rev 04)
00:1b.0 Audio device: Intel Corporation Lynx Point-LP HD Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation Lynx Point-LP PCI Express Root Port 1 (rev e4)
00:1c.2 PCI bridge: Intel Corporation Lynx Point-LP PCI Express Root Port 3 (rev e4)
00:1c.3 PCI bridge: Intel Corporation Lynx Point-LP PCI Express Root Port 4 (rev e4)
00:1c.4 PCI bridge: Intel Corporation Lynx Point-LP PCI Express Root Port 5 (rev e4)
00:1d.0 USB controller: Intel Corporation Lynx Point-LP USB EHCI #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation Lynx Point-LP LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation Lynx Point-LP SATA Controller 1 [AHCI mode] (rev 04)
00:1f.3 SMBus: Intel Corporation Lynx Point-LP SMBus Controller (rev 04)
06:00.0 Network controller: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter (rev 01)
07:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 07)
08:00.0 3D controller: NVIDIA Corporation GF117M [GeForce 610M/710M/820M / GT 620M/625M/630M/720M] (rev a1)
This laptop has two graphics cards, one is Intel HD 4400 another is Nvidia GeForce 820m (using Nvidia optimus technology). Intel i3-4030U CPU @ 1.90GHz. 4GB DDR3 1600 RAM. 500GB sata 3 hdd.


What works and what does not ?

  • VGA = Intel HD 4400 (works perfectly with standard kext's using fake id's)
  • Ethernet RTL8001E (works with additional kext)
  • Sound (partially works using latest VoodooHDA, for full working needs to patch AppleHDA and make correct DSDT patches using EAPD Codec Commander)
  • USB (works perfectly, for usb 3 needs to use xUSB additional kexts)
  • Wifi Atheros AR9565 (not working, does not have hardware support in OS X, no hacks are available to make it work)
  • TrackPad (works perfectly using additional kext)

First of all you need to find the source of the InstallUSB (disk image) on TPB or other sources. Here is the point to the correct direction. 6.94GB is the size of the correct install that contains these files  "Yosemite_final.raw" 6.94 GB, "ImageWriter.exe" 30.5 KB, "INSTALACAO.txt". You will also need the USB KEY 8GB. Then run ImageWriter.exe and select Yosemite_final.raw to write into Flash. Boot your computer from USB flash. Press "O" button on the boot menu entry "Install Yosemite" then at the line "Boot Args" press "ENTER" and add this text at the end of line "
nv_disable=1 dart=0 Intel=true". Press "ENTER" again then on the "Binaries patching menu" click on "Kernel PM Patch". Then two times return to the main boot loader menu or simply press "ESC" two times. Now boot the "Install Yosemite". The installer should boot correctly. Use disk utility to prepare the OS X partition, and install everything to it. Reboot, Boot with the same parameters. If you haven't installed Clover to EFI partition do it and add entry to clover boot loader, from bios. Use "File Browser Add Boot Option" Select EFI partition > EFI > CLOVER > CLOVERX64.efi. Now you should save changes to the BIOS and reboot the PC. Everything should start with the same parameters as in the installation procedure. After OS X boot you should mount efi partition and copy config.plist from the archive you downloaded. Open terminal. sudo su, enter your password and mount the partition.
# sudo su
# mkdir /Volumes/EFI
# mount -t msdos /dev/disk0s1 /Volumes/EFI
Then drag the config.plist to the EFI partition > EFI > CLOVER and overwrite it.
In terminal delete the unecessary Kext's 
# cd /System/Library/Extensions
# rm -rf AppleIntelHD* AppleIntelSNB* AMDRadeon* ATI* GeForce* NVDA* ApplePS* AppleHDA* 

Use Kext Wizard to simply install new kext's from Audio install: VoodooHDA.kext, from lan install RealtekLTL8100-RC1 kext, from VGA install two kexts. Finally from Trackpad folder read howto.

I think this tutorial is almost complete..

Feel free to post comment with a question!








8 comments:

  1. will this process works if i have same pc with i3 processor (4th gen) and having only intel graphics .

    ReplyDelete
  2. Yes, of course. I'm using Intel Graphics too. But depends what the device do you have and is it compatible with OS X kernel drivers with QE support or not.

    ReplyDelete
  3. Here are a few things to note. Not sure if they are needed but it is something to note:

    1) When you install OSX, use a USB 2.0 port. I was unable to get far using the USB 3.0 port.

    2) BIOS settings
    - AHCI
    - Virtualization is disabled
    - Secure Boot is disabled
    - Boot Option UEFI
    - Load Legacy ROM disabled

    3) When partitioning be sure to set the master boot record to GUID

    4) To get Wifi working you can buy a Dell 1510 wireless card off of ebay.

    ReplyDelete
  4. I'm still running into issues with getting the boot loader to work. I installed Clover with the - Install for UEFI booting only - Install Clover in the ESP. The ESP mount showed up and I copied over the config.plist file from the "Required packages". Reboot and the boot loader shows the parameters yet nothing loads and the screen is blank. I will try -v to see if any errors.

    ReplyDelete
  5. Thx for this! I got it work. But i find strange issue. Monitor brightness is not 100% and its impossible to change that until the monitor goes to sleep and then after wake up its 100% bright. Kext issue i think, but its too difficult for me.
    http://www.tonymacx86.com/yosemite-laptop-support/145427-fix-intel-hd4200-hd4400-hd4600-mobile-yosemite.html

    ReplyDelete
  6. AppleIntelLpssI2C: :probe fails :(

    ReplyDelete
  7. i have installed mac os x yosmite 10.10.1 on dell inspiron 3542 laptop (8GB RAM, i5 processor)using vm ware but the only problem is wifi connection........not connected ......actually wifi connection is not dispalying in the mac os ........ can anyone please to solve this problem......... whether if i need to install wifi driver where i will find those drivers ..........pls pls help me

    ReplyDelete

Copyright (c) 2012-2013 Unix Master. Powered by Blogger.